Celcius CTW forum

forum for everything CTW


You are not connected. Please login or register

My CTW is giving me lots of problems..

Go down  Message [Page 1 of 1]

1 My CTW is giving me lots of problems.. on Thu May 03, 2012 8:26 pm

Rash


Recruit
Recruit
Well as the title says, my CTW is going me crazy...

Let me explain it, first of all it's been over 10 months since i got it and it never work fine. I bougth it from Asiarsoft. After changing the esential chamber pieces and the m90 Systema It looked fine. But i couldn't even tried it. After 2 months the fps problem started and it shooted over 78fps...I change all the cilinder pieces and it finally work good. Then I got the Vanaras problems, when I used the "Pmag" Vanaras, i lost over 100fps... weird? i think so, but not enough, the motor started having some troubles when i started shooting. Finally all my fuses were blown. It looks like the motor is trying to move the gear and piston but he couldn't and the fuses just dead...

Sorry for the big post and my bad english but i'm so pissed off that i can't even try to write in the properly way,
and thanks for reading.

Rash

View user profile

2 Re: My CTW is giving me lots of problems.. on Sat May 05, 2012 12:37 pm

Sunray


Major
Major
Lets start simple - if you open the gun and try and move the sun gear (the thinner one of the 2 sticking out of the gearbox) by hand; can you?

If its 'stuck' or freely rotates in both directions without much effort then your Sun Gear has seperated....

Let us know what you find and we'll see where we go from there.....

cheers

View user profile

Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum