Celcius CTW forum

forum for everything CTW


You are not connected. Please login or register

Low FPS troubles shooting

View previous topic View next topic Go down  Message [Page 1 of 1]

1 Low FPS troubles shooting on Wed Mar 14, 2012 12:50 pm

Rash


Recruit
Recruit
Hello there! I didn't find any place to present my self so I'll take the opportunity to introduce myself here with this post.

I'm Rash from Spain and I have a Celcius Training Weapon M4A1 MX2.
I bought it 5 months ago in Asiarsoft. When it arrived I did all the normal mods. I changed the Celcius Chamber Packing and the Chamber Packing Base for the Systema ones. I putted the M100 Systema and everything went fine.

Here is when all my troubles started...
But then, after a few months without playing when I tried it I was surprised because it didn't work properly. THe FPS were around 140 and the BBs sometimes just fall rolling throw the inner barrel.
I checked if the Cylinder was moving, but it doesn't look like that.

I have no idea, what's is going on? I've bought a System full packing chamber and I'm waiting for it to arrive but I'm not sure. I think that won't change anythng. I'm also looking for a Deep fire inner barrel, would you recommend it?

Does any one knows what could it be?

Thank you a lot for reading!
Regards.

View user profile

2 Re: Low FPS troubles shooting on Thu Mar 15, 2012 8:06 am

Rash


Recruit
Recruit
No one knows what could it be?

View user profile

3 Re: Low FPS troubles shooting on Thu Mar 15, 2012 9:45 am

gycu


Sargeant
Sargeant
Try setting you hop-up to 0 (no hop at all) and try again. If it still does it, its not the hop_up.
If you can, try another cylinder, then another barrel+hop_up assembly; you should at least narrow it down..

Keep us posted,

Cheers!

View user profile

4 Re: Low FPS troubles shooting on Sun Mar 18, 2012 4:56 am

Trigger


Private
Private
You might have to relube your cylinder. Some time the piston head holes get clogged up and the oring has no air to expand I, causing lost of compression. Thats why your bb just roll out. Thats one thing I notice about systema cylinder grease. Hope that help.

View user profile

5 Re: Low FPS troubles shooting on Mon Apr 30, 2012 11:23 am

Rash


Recruit
Recruit
Thank you to everyone who helped me. I just got what was going wrong, I finally replaced the CLU-010 - Main O-Ring for Piston Head for a new one and i it retook the 340 FPS... Now i'm having some troubles with my vanaras polymerer mags, they give me like 100Fps less than the CTW originals and of course less distance when i shoot.
Shocked

View user profile

Sponsored content


View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum