Celcius CTW forum

forum for everything CTW


You are not connected. Please login or register

Just got a ctw in the mail, having some problems

Go down  Message [Page 1 of 1]

deadlyzach

avatar
Corporal
Corporal
Alright well to start off i did buy this brand new from evike, it is an MX2 and i am sure off that, so first problem was the polarity was completely backwards(i found that out after hooking up a battery and the gun did nothing)

After i fixxed that problem i got to shooting it and it did jam a few times but that was probably just the BB's i was using.

The one thing i am un sure off is that when i pull the trigger on semi it seems very slow like i cant quickly pull the trigger, its fast on auto just like it should be but when i use semi its like i pull the trigger quickly 3 times and only get 2 shots.
Im using a firefox 1600Mah 11.1v 12c battery, My first thought is maybe the battery is too weak but i just pulled it off the charger.

View user profile

Sunray


Major
Major
I would hazard a guess that its the control wire that links the trigger to the ECU board as I had something similar with a mate of mine and we replaced that and hey presto - all goooood!!!

cheers

View user profile

deadlyzach

avatar
Corporal
Corporal
So what exactly would i have to do to replace that ? sorry im kinda new to the CTW.
Also i tried using a 25c 11.1 2500MaH battery and it seemed to work alot better. Is there any chance that maybe the battery i was using is just not powerful enough ?

View user profile

Sunray


Major
Major
Just spotted that the battery you were using was only a 12C discharge lipo - this is probably a little low for a CTW or PTW.

Try and use a 20C rated battery as this is the speed the battery will discharge and the higher the better your CTW will perform.

The battery with the 25C discharge rate will be fine, but the 2500 mah may cause your rate of fire to be very high and may cause damage if your only running an M90 or M110 spring - only use these type of batteries for the M130 springs and above.

View user profile

Otter


Private
Private
Wait... mAh shouldn't affect the rof of fire on a lipo, or any other battery for that matter, should it? I thought that, with a lipo, the things that would contribute to a faster or lower rof would be the voltage (11.1 compared to 9.6) and the discharge rate (20c compared to 25c)

View user profile http://www.airsoftvt.com

deadlyzach

avatar
Corporal
Corporal
Ive noticed over the years that MaH can cause a slight change in ROF, Also maybe its just me not being used to the CTW but i think it sounds a little screechy compared to my standard aegs.

View user profile

Otter


Private
Private
Probably wasn't due to the mAh, but rather the quality of the battery/ wire that the battery is connected by. MaH means milliampere-hour, and it dictates how long the battery will last.

View user profile http://www.airsoftvt.com

gycu


Sargeant
Sargeant
deadlyzach wrote:Also maybe its just me not being used to the CTW but i think it sounds a little screechy compared to my standard aegs.
The "screechy" sound may be caused by some imperfect gear in the gearbox, or some mechanical imperfection in the whole gears/moving parts assembly; i have seen one ctw that sounds very "clean" compared with another that is quite noisy/screechy - i should mention that both ctws have the same rof

And another thing related to the ctw noise: try a ptw cylinder in the ctw, and see how the sound changes, coming more close to the ptw sound

View user profile

deadlyzach

avatar
Corporal
Corporal
I currently dont own a PTW cylinder, and as far as imperfection in the gears the only thing ive noticed is that the 2 small holes on the sector gear are cut so close that it actually looks like one single circle.

View user profile

papoose42


Sargeant
Sargeant
You must use at least a 20c battery

View user profile

Sponsored content


Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum